The issue has been identified and the fix has been implemented. We are actively monitoring the resolution.
Posted Apr 29, 2026 - 06:10 EDT
Update
We've identified the root cause of the recent issue affecting the Practice Pro application is related to billing statement generation. A fix is scheduled for deployment on April 29, 2026 at 5:45 AM EDT. Thank you for your patience while we work to resolve this. Further updates will be shared as needed.
Posted Apr 28, 2026 - 15:39 EDT
Identified
Reports of slowness in the Practice Pro application have subsided. Our engineering team is working on a hotfix currently, and we update again when we have an ETA for the deployment.
Posted Apr 28, 2026 - 13:56 EDT
Investigating
We are investigating intermittent reports of increased latency/slowness affecting Practice Pro application. Our engineering team is currently analyzing the root cause. Further updates will be provided in 30 minutes.